Destination to clipboard not working

Description

Capturing Destination "Copy to Clipboard" does not work all the time in this build. Settings are as attached. Replications steps:

Capture region
Verify clipboard is empty or has old value
Perform last capture
Verify clipboard now has screenshot

I tried some destination variations, some with success, some failed

FAILED
x Save Directly
x Copy to clipboard

FAILED
x Copy to clipboard

WORKED
FAILED
x Save Directly
x Open in image editor
x Copy to clipboard

Environment

Windows 10 OS build 19042.746 Version 20H2
Greenshot 1.2.10 Build 6 (64 bit)

Activity

Show:
Robin Krom
February 10, 2021, 7:31 AM

You can remove the greenshot.ini file here, make sure it’s not running: %APPDATA%\Greenshot

(Yes, you can copy that into the file explorer)

A new file will be generated with all the default settings.

George Bica
February 10, 2021, 7:50 AM

I have narrowed this problem down to Region Capture mode problem, Windows, Full, Last modes work fine.

Region Capture fails regardless of activation mode, hotkey, right click, etc. I terminated the process and renamed the ini file in AppData but the problem persists.

The strange part is the system tray notification says “Exported to: copy to clipboard” but there is no actual data stored.

Robin Krom
February 10, 2021, 7:53 AM

Okay, I'll check it out in the next day(s), thanks for narrowing it down. I actually only tested it with window capture only, so that information might help.

 

George Bica
February 10, 2021, 8:20 AM

OK, I will also check with a different PC. If this is computer specific, is there anything you can think of that would break this functionality? It was working before, just found it recently.

George Bica
3 days ago

Testing on a different PC shows this works as expected. Further testing by me revealed that the source of the problem is not Greenshot. I identified that Putty also could not highlight text as normal to copy to clipboard for later paste. I was getting the ^C after highlighting any text on the console.

 

I turned off all running apps on the computer until I found that Qtranslate and specifically its Mouse Mode ON causes this interference. This case can be closed.

Assignee

Unassigned

Reporter

George Bica

Affects versions

Components

Priority

Minor

Labels