1.3.71: Error when capturing screen and select "open in image editor"

Description

If I capture part of the screen and then select "Open in image editor" I receive the shown below. If, however, I capture again (while the other error is still on the screen) then I don't receive an error. If I close all open instances of the image editor and then capture the screen again the error returns...

Software version: 1.3.71 - 3055d42689 (64 bit)
.NET runtime version: 4.0.30319.42000+
Time: 2020-04-15 09:25:50 +01:00
OS: Windows 10 1909 x64 build 18363
GDI object count: 88
User object count: 91

Exception: System.Exception
Message: Element not found. (Exception from HRESULT: 0x80070490)

Stack:
at Windows.UI.Notifications.ToastNotifier.get_Setting()
at GreenshotWin10Plugin.ToastNotificationService.ShowMessage(String message, Int32 timeout, Action onClickAction, Action onClosedAction) in d:\a\1\s\GreenshotWin10Plugin\ToastNotificationService.cs:line 83
at Greenshot.Helpers.CaptureHelper.SurfaceMessageReceived(Object sender, SurfaceMessageEventArgs eventArgs) in d:\a\1\s\Greenshot\Helpers\CaptureHelper.cs:line 555
at GreenshotPlugin.Interfaces.SurfaceMessageEventHandler.Invoke(Object sender, SurfaceMessageEventArgs e)
at Greenshot.Drawing.Surface.SendMessageEvent(Object source, SurfaceMessageTyp messageType, String message) in d:\a\1\s\Greenshot\Drawing\Surface.cs:line 1003
at GreenshotPlugin.Core.AbstractDestination.ProcessExport(ExportInformation exportInformation, ISurface surface) in d:\a\1\s\GreenshotPlugin\Core\AbstractDestination.cs:line 109
at Greenshot.Destinations.EditorDestination.ExportCapture(Boolean manuallyInitiated, ISurface surface, ICaptureDetails captureDetails) in d:\a\1\s\Greenshot\Destinations\EditorDestination.cs:line 118
at GreenshotPlugin.Core.AbstractDestination.<>c_DisplayClass28_0.<ShowPickerMenu>b_4(Object sender, EventArgs e) in d:\a\1\s\GreenshotPlugin\Core\AbstractDestination.cs:line 207
at System.Windows.Forms.ToolStripItem.RaiseEvent(Object key, EventArgs e)
at System.Windows.Forms.ToolStripMenuItem.OnClick(EventArgs e)
at System.Windows.Forms.ToolStripItem.HandleClick(EventArgs e)
at System.Windows.Forms.ToolStripItem.HandleMouseUp(MouseEventArgs e)
at System.Windows.Forms.ToolStrip.OnMouseUp(MouseEventArgs mea)
at System.Windows.Forms.ToolStripDropDown.OnMouseUp(MouseEventArgs mea)
at System.Windows.Forms.Control.WmMouseUp(Message& m, MouseButtons button, Int32 clicks)
at System.Windows.Forms.Control.WndProc(Message& m)
at System.Windows.Forms.ToolStrip.WndProc(Message& m)
at System.Windows.Forms.ToolStripDropDown.WndProc(Message& m)
at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)

Configuration dump:

Environment

None

Activity

Show:
Lee Wilmott
April 15, 2020, 9:30 AM

Please ignore me! I restarted my workstation and the problem hasn’t occurred. Sorry for the premature posting.

Robin Krom
April 24, 2020, 8:22 PM

Well actually the issue only occurs once, but I fixed it in any build after that one.

Robin Krom
April 24, 2020, 8:22 PM

Solved

Assignee

Unassigned

Reporter

Lee Wilmott

Affects versions

None

Components

None

Priority

Major
Configure